[gpfsug-discuss] question about why unix extensions = no is recommended when using samba + gpfs?

Sabuj Pattanayek sabujp at gmail.com
Wed Apr 2 22:24:14 BST 2014

Seems like the workaround for now is to set :

gpfs:sharemodes = no


Could be a regression? Haven't tried yet, but we will be upgrading
to that soon.

On Wed, Apr 2, 2014 at 4:05 PM, Sabuj Pattanayek <sabujp at gmail.com> wrote:

> So I've been using the recommended gpfs:acl = yes mode for a while on
> windows/cifs/smb only shares and today came across a bug where Microsoft
> Office (2010, haven't tried other versions) on Windows 7/8 refuses to save
> or save as. It can clearly create tmp files (e.g. those ~$... files when it
> opens a file) and I can right click -> create a new file, edit files in
> notepad/wordpad, drag and drop files between explorer windows but whenever
> I try to save a doc/docx or xls/xlsx file it always throws the error dialog
> :
> There has been a network or file permission error. The network connection
> may be lost. (mapped drive:\folder\fileName.docx)
> ( OK )   ( Help )
> Was this information helpful?
> If i switch to gpfs:acl = no and then use vfs_acl_xattr instead it works
> fine. MS Office on OSX does not have this problem
> It's similar to this issue :
> https://www.ibm.com/developerworks/community/forums/html/topic?id=77777777-0000-0000-0000-000014299075
> Anyone have any ideas without having to use acl_xattr? Again I'm using
> sernet samba 4.1.6 and gpfs .
> Thanks,
> Sabuj
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://gpfsug.org/pipermail/gpfsug-discuss_gpfsug.org/attachments/20140402/42d9eb85/attachment-0003.htm>

More information about the gpfsug-discuss mailing list