[gpfsug-discuss] Windows xattr/Samba

Jonathan Buzzard j.buzzard at dundee.ac.uk
Wed Aug 15 23:07:34 BST 2012

Barry Evans wrote:
> Hello all,
> Anyone had success with windows extended attributes actually passing
> through samba over to GPFS?
> On a 3.4.0-13 system with samba 3.5.11 when trying to set a file read
> only through Win 7 explorer and attrib I get:
> [2012/08/15 18:13:32.023966,  1]
> modules/vfs_gpfs.c:1003(gpfs_get_xattr) gpfs_get_xattr: Get GPFS
> attributes failed: -1
> This is with gpfs:winattr set to yes. I also tried enabling 'store
> dos attributes' for a laugh but the result was no different. I've not
> tried bumping up the loglevel yet, this may reveal something more
> interesting.

Hum, worked for me with 3.4.0-13 and now with 3.4.0-15, using samba3x
packages that comes with CentOS 5.6 in the past and CentOS 5.8
currently. Note I have to rebuild the Samba packages to get the vfs_gpfs
module which you need to load. The relevant bits of the smb.conf are

# general options
        vfs objects = shadow_copy2 fileid gpfs

# the GPFS stuff
         fileid : algorithm = fsname
         gpfs : sharemodes = yes
         gpfs : winattr = yes
         force unknown acl user = yes
         nfs4 : mode = special
         nfs4 : chown = no
         nfs4 : acedup = merge

# store DOS attributes in extended attributes (vfs_gpfs then stores them
in the file system)
        ea support = yes
        store dos attributes = yes
        map readonly = no
        map archive = no
        map system = no
        map hidden = no

Though I would note that working out what all the configuration options
required to make this (and other stuff) work where took some
considerable amount of time. I guess there is a reason why IBM charge
$$$ for the SONAS and StoreWise Unified products.

Note that if you are going for that full make my Samba/GPFS file server
look as close as possible to a pucker MS Windows server, you might want
to consider setting the following GPFS options


All fairly self explanatory, and make GPFS follow Windows schematics
more closely, though they are "undocumented".

There is also there is an undocumented option for ACL's on mmchfs (I am
working on 3.4.0-15) so that you can do

      mmchfs test -k samba

Even shows up in the output of mmlsfs. Not entirely sure what samba
ACL's are mind you...


Jonathan A. Buzzard                      Tel: +441382-386998
Storage Administrator, College of Life Sciences
University of Dundee, DD1 5EH

The University of Dundee is a registered Scottish Charity, No: SC015096

More information about the gpfsug-discuss mailing list